OSPF基础知识概述-yzc888亚洲城系统官网

yzc888

  • 热门搜索:
  • yzc888亚洲城手机版
  • 雨林木风系统
  • 深度系统
  • 电脑公司系统
  • win7装机版
  • 教程分类
    当前位置:主页 > 教程咨询 > Linux教程

    OSPF基础知识概述

    来源:yzc888亚洲城┆发布时间:2018-10-12 06:00┆点击:

    yzc888亚洲城为您提供OSPF基础知识概述的文章咨询供您阅读,如何使用OSPF基础知识概述的方法对您有帮助也请您举手之劳分享给您身边的人。

    OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议(Interior Gateway Protocol,简称IGP),用于在单一自治系统(autonomous system,AS)内决策路由。是对链路状态路由协议的一种实现,隶属内部网关协议(IGP),故运作于自治系统内部。著名的迪克斯加算法(Dijkstra)被用来计算最短路径树。OSPF分为OSPFv2和OSPFv3两个版本,其中OSPFv2用在IPv4网络,OSPFv3用在IPv6网络。OSPFv2是由RFC 2328定义的,OSPFv3是由RFC 5340定义的。与RIP相比,OSPF是链路状态协议,而RIP是距离矢量协议。

    因为OSPF路由器之间会将所有的链路状态(LSA)相互交换,毫不保留,当网络规模达到一定程度时,LSA将形成一个庞大的数据库,势必会给OSPF计算带来巨大的压力;为了能够降低OSPF计算的复杂程度,缓存计算压力,OSPF采用分区域计算,将网络中所有OSPF路由器划分成不同的区域,每个区域负责各自区域精确的LSA传递与路由计算,然后再将一个区域的LSA简化和汇总之后转发到另外一个区域,这样一来,在区域内部,拥有网络精确的LSA,而在不同区域,则传递简化的LSA。区域的划分为了能够尽量设计成无环网络,所以采用了Hub-Spoke的拓朴架构,也就是采用核心与分支的拓朴,如下图:

    区域的命名可以采用整数数字,如1、2、3、4,也可以采用IP地址的形式,0.0.0.1、0.0.0.2,因为采用了Hub-Spoke的架构,所以必须定义出一个核心,然后其它部分都与核心相连,OSPF的区域0就是所有区域的核心,称为BackBone 区域(骨干区域),而其它区域称为Normal 区域(常规区域),在理论上,所有的常规区域应该直接和骨干区域相连,常规区域只能和骨干区域交换LSA,常规区域与常规区域之间即使直连也无法互换LSA,如上图中Area 1、Area 2、Area 3、Area 4只能和Area 0互换LSA,然后再由Area 0转发,Area 0就像是一个中转站,win7装机版,两个常规区域需要交换LSA,只能先交给Area 0,再由Area 0转发,而常规区域之间无法互相转发。

    OSPF区域是基于路由器的接口划分的,而不是基于整台路由器划分的,一台路由器可以属于单个区域,也可以属于多个区域,如下图:

    如果一台OSPF路由器属于单个区域,即该路由器所有接口都属于同一个区域,那么这台路由器称为Internal Router(IR),如上图中的R2,R3和R4;如果一台OSPF路由器属于多个区域,即该路由器的接口不都属于一个区域,那么这台路由器称为Area Border Router (ABR),如上图中的R1,ABR可以将一个区域的LSA汇总后转发至另一个区域;如果一台OSPF路由器将外部路由协议重分布进OSPF,那么这台路由器称为Autonomous System Boundary Router (ASBR),如上图中,R5将EIGRP重分布进OSPF,那么R5就是ASBR,但是如果只是将OSPF重分布进其它路由协议,则不能称为ASBR。

    Internal Router:域内路由器

    ABR(Area Border Router):区域边界路由器

    Backbone Router(BR):骨干路由器

    ASBR(Autonomous System Boundary Router):自治系统边界路由器.

    配置LOOPBACK接口地址

    ROUTER(config)#interface loopback 0

    ROUTER(config)#ip address IP地址 掩码

    ospf区域的配置

    router ospf 100 / 区域号在锐捷低端设备(交换机S3550,路由器R2621)里是不需要指定区域号的/

    network 192.168.1.0 0.0.0.255 area 0

    router-id 192.168.2.1 手动设置router-id

    area 1 default-cost 50 手动设置开销

    #clean ip ospf process

    配置ospf明文认证

    interface s0

    ip ospf authentication

    ip ospf authentication-key <;密码>

    配置ospf密文认证

    interface s0

    ip ospf authentication

    ip ospf message-digest-key 1 md5 7 <;密码>

    debug ip ospf adj 开启ospf调试

    show ip protocols

    show ip ospf interface s0

    手动配置接口花销,带宽,优先级

    inter s0

    ip ospf cost 200

    bandwidth 100

    ip ospf priority 0

    虚链路的配置

    router ospf 100

    area <area-id> virtual-link <router-id>

    show ip ospf virtual-links

    Show ip ospf border-routers

    Show ip ospf process-id

    Show ip ospf database

    show ip ospf database nssa-external

    OSPF路由归纳

    Router ospf 1\对ASBR外部的路由进行路由归纳

    Summary-address 200.9.0.0 255.255.0.0

    Router ospf 1\执行AREA1到AREA0的路由归纳

    Area 1 range 192.168.16.0 255.255.252.0

    配置末节区域

    IR area <area-id> stub

    ABR area <area-id> stub

    配置完全末节区域

    IR area <area-id> stub

    ABR area <area-id> stub no-summary

    配置NSSA

    ASBR router ospf 100

    area 1 nssa

    ABR router ospf 100

    area 1 nssa default-information-orrginate

    OSPF协议主要优点

    1、OSPF是真正的LOOP- FREE(无路由自环)路由协议。源自其算法本身的优点。(链路状态及最短路径树算法)

    2、OSPF收敛速度快:能够在最短的时间内将路由变化传递到整个自治系统。


    以上就是yzc888亚洲城给大家介绍的如何使用OSPF基础知识概述的方法了,如何使用OSPF基础知识概述的方法到这里也全部结束了相信大家对如何使用OSPF基础知识概述的方法都有一定的了解了吧,好了,如果大家还想了解更多的资讯,那就赶紧点击yzc888亚洲城系统官网吧。

    本文来自yzc888亚洲城www.zhuangjiyuan.com如需转载请注明!

    Tag标签| RSS订阅 | 网站地图
    yzc888亚洲城系统之家提供win7装机版xp系统下载win7系统下载、最新Windows10系统下载,专为装机修机员奉上最好的软件、系统、U盘pe、程等平台
    请勿发布违反国家法律法规的内容,会员观点不代表本站立场.本站发布的系统与软件仅为个人学习测试使用,请在下载后24小时内删除,不得用于任何商业用途,
    否则后果自负,请支持购买微软正版软件! 如侵犯到您的权益,请及时通知我们,我们会及时处理。 粤ICP备15116662号